Help

We expect to add to this page as needed if common support questions come in. As always, feel free to email us if you need help.

“The login link isn’t working for me.”

Try this link. If that doesn’t work, email Josh@EqualRightsInstitute.com and we’ll get it figured out.

“The website seems slow.”

Yes, we’ve noticed this too. We’ll be talking to our hosting service about it, as well as doing a few things on our end that should speed up the website a bit. We’re hoping to see significant improvement in the next few weeks.

“I need help figuring out how to put the course MP3’s or podcasts on your phone.”

Click here for a helpful tutorial.

” I’m having problems streaming the lesson videos.”

We paid for a premium video hosting service (Wistia) which is used by many of the top online courses. Here are a few things you can try that often help. (The third step completely solved the problem for us when we had a streaming issue once.)

  • Is Your Internet Speed Being Bogged Down?
    • Is someone else watching Netflix or YouTube, or on a Skype call? Are you backing up your files to Dropbox? Minimize the devices using up your WiFi for the best results.
  • Check Your Internet Speed
    • Go to SpeedTest.net to check your internet speed.
    • The minimum viable connection speed to stream Wistia video reliably is about 768 kilobits per second (equal to .768 megabits per second). We recommend a connection speed of at least 5 megabits per second for an optimal experience with HD capability.
  • Clear Your Cache
    • Like with video uploading problems, it may seem silly, but it’s an amazing fix in a number of situations. Try clearing your browser’s cache and restarting your web browser.
      • Chrome: Preferences –> Show advanced settings… –> Browsing data
      • Safari: Preferences –> Privacy —> Remove All Browsing Data
      • Firefox: History –> Clear recent history
      • Internet Explorer: Tools –> Internet Options –> Browsing History
  • Reset Your Internet Connection
    • Try resetting your router. Unplug it and plug it back in after around 45-seconds. After plugging it back in expect it to take a few minutes for it to reestablish a fresh (and probably faster) connection.
  • Try a Different Browser
    • Sometimes different browsers can cause problems. If you’re using Firefox and your video doesn’t play, but things are hunky-dory in Chrome, let us know!